Website and Slack application is slow
Incident Report for FireHydrant
Resolved
This incident has been resolved.
Posted Dec 04, 2024 - 18:48 UTC
Update
New incident behavior should be working as expected. We are continuing to work through the backlog of events in the queue and monitoring performance
Posted Dec 04, 2024 - 18:20 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Dec 04, 2024 - 18:19 UTC
Update
We are continuing to work through the queue of backlogged requests and monitoring performance
Posted Dec 04, 2024 - 18:04 UTC
Update
We are continuing to work through the queue of backlogged requests
Posted Dec 04, 2024 - 17:48 UTC
Update
We have identified the issue and are continuing to work through a backlog of requests in the queue
Posted Dec 04, 2024 - 17:32 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Dec 04, 2024 - 16:38 UTC
Update
Our systems have detected an availability or performance update with Slack and we're investigating the impact. Additionally, our site is currently experiencing a higher than normal load time, and may be causing pages to be slow or unresponsive.

We're investigating the cause and will provide an update as soon as possible.
Posted Dec 04, 2024 - 16:22 UTC
Investigating
We are currently investigating this issue.
Posted Dec 04, 2024 - 16:16 UTC