Signals-adjacent features are lagging

Incident Report for FireHydrant

Resolved

This incident has been resolved.
Posted Jul 02, 2025 - 16:46 UTC

Update

We have worked through the backlog of alerts and are monitoring performance
Posted Jul 02, 2025 - 16:03 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Jul 02, 2025 - 16:01 UTC

Update

We have identified an issue with Signals escalation policies. New escalation targets created within the last 2 hours will see a lag in receiving alerts. We have identified the issue and are working through the backlog.
Posted Jul 02, 2025 - 15:56 UTC

Investigating

We are currently investigating this issue.
Posted Jul 02, 2025 - 15:54 UTC